PDA

View Full Version : "While the world is running" event not workin in 2.4.1


michaelleih
01-03-2014, 03:52 PM
I just installed 2.4.1 and was running several of my old programs and noticed that when the "When the world starts, do" event is converted to the "While the world is running" event, the "While the world is running" never executes the methods indicated in "Begin", "During", or "End" parameters. I have tried this on Windows 7 and Windows 8. Any thoughts?

MrMoke
01-08-2014, 09:38 PM
You are correct. It may be yet another bug introduced with the 2.4.1 release, many of which are now breaking numerous "while" events in older programs. However, in my older Worlds 2.4.1 still shows the "when worlds starts" event, as well as do new Worlds.

The "while world is Running" option would appear to be a good way to get background tasks like wave action. However, the only real way to stop a world is to click the "Stop" button, and doing so prevents the "end" event from executing anyway.

In the past I just created a global Boolean variable, and let it control anything that needed to run in an infinite loop until the game is over.

MrMoke
05-12-2014, 10:24 AM
I've attached a quickie to demo.

Try it on 2.3.5 and then 2.4.1 to see major differences.

jrrTolkien
05-12-2014, 12:07 PM
Same with mine :( I just use when the worl starts, an it works just as well most of the time. :)

-Jrr ;)

MrMoke
05-15-2014, 06:55 PM
Tried the Beta release of 2.4.2 and it's looking good so far. I recommend moving up, and reporting anything you may find.