PDA

View Full Version : Factory Test - An Alice 3 and NetBeans Project


DrJim
06-29-2009, 07:05 PM
Attached is a brief Alice 3 test I did in response to an earlier posting in the forum ( http://www.alice.org/community/showthread.php?p=10845&posted=1#post10845 ). The zipped folder contains the Alice 3 Project, a .jar version created in NetBeans, a .bat file to run the .jar version, a "lib" folder needed to run the .jar version and a text file essentially repeating this and the next paragraph. You will need to have Alice 3 and the JRE installed on your machine, but Alice 3 does not need to be running to run the .jar version of the project - just click on the icon for the .bat file.

:eek: Caution: Do not copy or move the "lib" folder. This is a very common folder name and you may corrupt other programs having their own "lib" folder. :eek:

In respose to the question in the earlier posting, I did not have any trouble with this version of the project. However when I tried to put the individual gears in an array, I was unsuccessful. Just trying to build the (model) array failed completely. I could make the array - but not hit OK to finalize it. Making a "custom array" for "All in --- together" worked, but I got an error actually trying to run the project. Those problems were all in Alice 3, not NetBeans.

:D Fun, fun, fun. :D

DrJim
06-29-2009, 08:55 PM
One thing I forgot to mention in the preceeding post :o is that the file paths in the .bat file assume you did the default Alice 3 installation.

If not, you are going to have to find the equivalent paths for your installation and modify the .bat file accordingly (hit right click/edit).