PDA

View Full Version : no jni_nebulous in java.library.path


cayhorstmann
08-15-2009, 10:20 AM
I am trying to run the Alice plugin (.60) in Netbeans 6.7.1 on Linux and get this error:

java.lang.UnsatisfiedLinkError: no jni_nebulous in java.library.path

What is jni_nebulous? Google never heard of it.

Thanks,

Cay

cayhorstmann
08-22-2009, 12:11 AM
Now I installed the Linux version--thanks for the installer. In Alice, my little project runs just fine. But when I try to run it inside Netbeans, I get this:

*** glibc detected *** /home/apps/jdk1.6.0_14/jre/bin/java: double free or corruption (out): 0x6db00e08 ***
======= Backtrace: =========
/lib/tls/i686/cmov/libc.so.6[0xb7eb6604]
/lib/tls/i686/cmov/libc.so.6(cfree+0x96)[0xb7eb85b6]
/lib/tls/i686/cmov/libc.so.6(fclose+0x144)[0xb7ea5fe4]
/home/cay/.netbeans/6.7/libs/stage.jar-natives-linux-i586/libjni_nebulous.so(_ZN12slIllIIIIIlI6Person12slIll lIllIIlEv+0x2f0)[0x6ef64f40]
/home/cay/.netbeans/6.7/libs/stage.jar-natives-linux-i586/libjni_nebulous.so(_Z13slIIlllIIlIIlP7JNIEnv_P8_jo bject+0x63)
...