PDA

View Full Version : Sims people walking


SlithyToves
09-11-2010, 03:43 PM
I have tried to make the customized (Sims) people walk, but I just can't figure out how:confused:. There is no procedure for it, and the people don't have any subparts, so I can't make a procedure. Would making the people walk be possible? How would I go about doing it?

DensetsuNoKaboom
09-12-2010, 05:32 PM
Oh boy...people without subparts...

Well, here's the short answer: No.

If you want a long answer, if you're an excellent 3D modeler, I bet there's some way to import the models into a 3D modeling software, and create subparts for them. That may or may not be possible, you'll have to ask one of the more experienced 3D modelers in the forums.
Alternatively, you could try using people from the old Alice 2 gallery.
If you really need the Sims to walk, you could just make them move normally. It's much lower quality, but much more practical.

If Gabe reads this topic, please tell the development team to GIVE THE SIMS SUBPARTS!

Oh hey, I have 350 posts now!

SlithyToves
09-12-2010, 05:36 PM
If you really need the Sims to walk, you could just make them move normally.

What do you mean by 'move normally'?

DensetsuNoKaboom
09-12-2010, 05:37 PM
I mean like, "Sims person move forward 5 meters" move normally.

SlithyToves
09-12-2010, 05:40 PM
Aah. Thanks for your help!:D I still would like to use the Sims people for walking though...:( The Alice 2 people don't look nearly as good, and they aren't custom.

I agree with DensetsuNoKaboom, the Sims people should have subparts.

dang
09-13-2010, 10:26 AM
One way to do this, although still not a good old fashioned "walk" method amongst the myriad of belching, farting, panicking about urinating and so on, is to try do together (shuffleFeet + move) or do together(jogInPlace + move) depending on if you want it to look more like jogging or shuffling feet. Some caveats about doing this:

- do together
this.guy move FORWARD 2.0
this.guy jogInPlace

But that has a couple of issues:
1) well, do _you_ walk like that? it looks goofy
2) being pulled forward is obvious as the feet are drug along the ground when the feet are down

- do together
this.guy move FORWARD 2.0
this.guy shuffleFeet

better but you still get into trouble if you:
- move too much or too fast, it looks like you're being drug along the ground while moving your feet
- move too little or too slow, it looks like you're... well... jogging in place while being drug along the ground slowly

Best regards,

-- DanG
Daniel Green, Oracle Corporation

SlithyToves
09-13-2010, 02:24 PM
Thanks for your help, DanG. You're right, it does work. It doesn't look all that natural, but it looks a lot better than sliding across the ground:p. I also noticed that the shuffleFeet procedure is not available for children:confused:, so this wouldn't work for them, am I correct? Thank you for your help again.

dang
09-15-2010, 04:32 PM
You're quite welcome.
> I also noticed that the shuffleFeet procedure is not available
> for children, so this wouldn't work for them, am I correct?

Unfortunately, yes. For some reason SIMs kids don't have as many procedures as the SIMs adults. Not sure why. "shuffleFeet" didn't make the cut for some reason.

Another problem with this approach is if you just do "do together (move + shuffleFeet) is that you have to play with the amount of time ("duration") spent moving vs. how long it takes to shuffleFeet

One thing you might look at is that, for now, some of the Looking Glass characters have reasonable walk procedures that come with the objects.

Best regards,

-- DanG
Daniel Green, Oracle Corporation


Thank you for your help again.

MiR
09-16-2010, 09:11 AM
... btw: Where do you get the children from? Have I missed any update actually from Alice3b0064?

SlithyToves
09-16-2010, 09:57 AM
The latest version is 3.0.0.2.9, I still have 3.0.0.2.3;) just noticed that I too need to update. You can get the latest version at http://www.alice.org/3. I have noticed that the version on the Project Kenai page is not the latest, also all references to the Kenai page have been removed on the Alice 3 page.

Hope this helps!

MiR
09-16-2010, 11:09 AM
OK, thanks for the tip.
I know this is not the technical help page, but...
I upgraded from 3.0.0.0.64 to 3.0.0.2.9 and now Alice won't start anymore...

I would appreciate any help, as this is very unusual for me...

My System: Ubuntu 9.10
Error: Unable to load OpenGL
Output from the console:

version: 3.0.0.2.9
comboBoxUI: javax.swing.plaf.synth.SynthComboBoxUI@1694eca
comboBoxUI: javax.swing.plaf.synth.SynthComboBoxUI@1fb050c
setLocale en_US
java.util.Locale.getDefault() de_DE
javax.swing.JComponent.getDefaultLocale() de_DE
platform: Linux-i386
library path: /host/data/Alice3/Alice3Beta/application/linux-i586

UNABLE TO LOAD OPENGL
------ -- ---- ------
The most common reason for this is an incorrectly set Java library path. Please update your VM arguments.
The text below has been copied to the clipboard for your convenience.
Linux-i386

all properties
--- ----------
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<!DOCTYPE properties SYSTEM "http://java.sun.com/dtd/properties.dtd">
<properties>
<comment>comment</comment>
<entry key="java.runtime.name">Java(TM) SE Runtime Environment</entry>
<entry key="sun.boot.library.path">/usr/lib/jvm/java-6-sun-1.6.0.20/jre/lib/i386</entry>
<entry key="java.vm.version">16.3-b01</entry>
<entry key="java.vm.vendor">Sun Microsystems Inc.</entry>
<entry key="java.vendor.url">http://java.sun.com/</entry>
<entry key="path.separator">:</entry>
<entry key="java.vm.name">Java HotSpot(TM) Server VM</entry>
<entry key="file.encoding.pkg">sun.io</entry>
<entry key="sun.java.launcher">SUN_STANDARD</entry>
<entry key="user.country">DE</entry>
<entry key="sun.os.patch.level">unknown</entry>
<entry key="java.vm.specification.name">Java Virtual Machine Specification</entry>
<entry key="user.dir">/host/data/Alice3/Alice3Beta</entry>
<entry key="java.runtime.version">1.6.0_20-b02</entry>
<entry key="java.awt.graphicsenv">sun.awt.X11GraphicsEnvironment</entry>
<entry key="java.endorsed.dirs">/usr/lib/jvm/java-6-sun-1.6.0.20/jre/lib/endorsed</entry>
<entry key="os.arch">i386</entry>
<entry key="java.io.tmpdir">/tmp</entry>
<entry key="line.separator">
</entry>
<entry key="java.vm.specification.vendor">Sun Microsystems Inc.</entry>
<entry key="os.name">Linux</entry>
<entry key="sun.jnu.encoding">UTF-8</entry>
<entry key="java.library.path">/host/data/Alice3/Alice3Beta/application/linux-i586</entry>
<entry key="java.specification.name">Java Platform API Specification</entry>
<entry key="java.class.version">50.0</entry>
<entry key="sun.management.compiler">HotSpot Tiered Compilers</entry>
<entry key="os.version">2.6.31-22-generic</entry>
<entry key="user.home">/home/mir</entry>
<entry key="user.timezone"/>
<entry key="java.awt.printerjob">sun.print.PSPrinterJob</entry>
<entry key="file.encoding">UTF-8</entry>
<entry key="java.specification.version">1.6</entry>
<entry key="java.class.path">/host/data/Alice3/Alice3Beta/ext/apple/AppleJavaExtensions.jar:/host/data/Alice3/Alice3Beta/ext/jaf/activation.jar:/host/data/Alice3/Alice3Beta/ext/jira/jira-soapclient-4.0-with-dependencies.jar:/host/data/Alice3/Alice3Beta/ext/jmf/JMF-2.1.1e/lib/customizer.jar:/host/data/Alice3/Alice3Beta/ext/jmf/JMF-2.1.1e/lib/jmf.jar:/host/data/Alice3/Alice3Beta/ext/jmf/JMF-2.1.1e/lib/mediaplayer.jar:/host/data/Alice3/Alice3Beta/ext/jmf/JMF-2.1.1e/lib/multiplayer.jar:/host/data/Alice3/Alice3Beta/ext/jmfmp3/lib/ext/mp3plugin.jar:/host/data/Alice3/Alice3Beta/ext/jogl/lib/gluegen-rt.jar:/host/data/Alice3/Alice3Beta/ext/jogl/lib/jogl.jar:/host/data/Alice3/Alice3Beta/ext/mail/lib/dsn.jar:/host/data/Alice3/Alice3Beta/ext/mail/lib/imap.jar:/host/data/Alice3/Alice3Beta/ext/mail/lib/mailapi.jar:/host/data/Alice3/Alice3Beta/ext/mail/lib/pop3.jar:/host/data/Alice3/Alice3Beta/ext/mail/lib/smtp.jar:/host/data/Alice3/Alice3Beta/ext/mail/mail.jar:/host/data/Alice3/Alice3Beta/ext/modified_nimbus/modified_nimbus.jar:/host/data/Alice3/Alice3Beta/ext/rpc/xmlrpc-client-1.1.jar:/host/data/Alice3/Alice3Beta/ext/swingworker/swing-worker-1.2.jar:/host/data/Alice3/Alice3Beta/ext/wrapped_flow_layout/wrapped_flow_layout.jar:/host/data/Alice3/Alice3Beta/ext/youtube/google-collect-1.0-rc1.jar:/host/data/Alice3/Alice3Beta/ext/youtube/youtube.jar:/host/data/Alice3/Alice3Beta/gallery/mtwtGalleryBoxes.jar:/host/data/Alice3/Alice3Beta/gallery/mtwtGalleryLargeIcons.jar:/host/data/Alice3/Alice3Beta/gallery/stagePersonEditorLargeIcons.jar:/host/data/Alice3/Alice3Beta/lib/3.0.0.2.9/alicecore.jar</entry>
<entry key="user.name">mir</entry>
<entry key="org.alice.ide.IDE.install.dir">/host/data/Alice3/Alice3Beta</entry>
<entry key="java.vm.specification.version">1.0</entry>
<entry key="java.home">/usr/lib/jvm/java-6-sun-1.6.0.20/jre</entry>
<entry key="sun.arch.data.model">32</entry>
<entry key="user.language">de</entry>
<entry key="java.specification.vendor">Sun Microsystems Inc.</entry>
<entry key="java.vm.info">mixed mode</entry>
<entry key="java.version">1.6.0_20</entry>
<entry key="java.ext.dirs">/usr/lib/jvm/java-6-sun-1.6.0.20/jre/lib/ext:/usr/java/packages/lib/ext</entry>
<entry key="sun.boot.class.path">/usr/lib/jvm/java-6-sun-1.6.0.20/jre/lib/resources.jar:/usr/lib/jvm/java-6-sun-1.6.0.20/jre/lib/rt.jar:/usr/lib/jvm/java-6-sun-1.6.0.20/jre/lib/sunrsasign.jar:/usr/lib/jvm/java-6-sun-1.6.0.20/jre/lib/jsse.jar:/usr/lib/jvm/java-6-sun-1.6.0.20/jre/lib/jce.jar:/usr/lib/jvm/java-6-sun-1.6.0.20/jre/lib/charsets.jar:/usr/lib/jvm/java-6-sun-1.6.0.20/jre/classes</entry>
<entry key="java.vendor">Sun Microsystems Inc.</entry>
<entry key="swing.aatext">true</entry>
<entry key="file.separator">/</entry>
<entry key="java.vendor.url.bug">http://java.sun.com/cgi-bin/bugreport.cgi</entry>
<entry key="sun.io.unicode.encoding">UnicodeLittle</entry>
<entry key="sun.cpu.endian">little</entry>
<entry key="sun.desktop">gnome</entry>
<entry key="sun.cpu.isalist"/>
</properties>


Possibly, the jogl library module .so for linux-i586 is missing? At least I found no trace in the subdirs of my install...

SlithyToves
09-16-2010, 12:12 PM
I feel so bad for you!:( I figured that newer is better, which, apparently, is not true:confused:, at least not in your case. I am not an expert at this kind of thing, so I can't really help. You might want to post your problem at the Bugs and Troubleshooting forum (http://www.alice.org/community/forumdisplay.php?f=18), where somebody who knows something might be able to help you.

MiR
09-16-2010, 12:50 PM
No problem, I sorted this bug out.
The 0.29 package did not contain the so libraries for linux-i586.
After downloading an older package and extracting the libs from there, Alice started normaly.
It just failed to import older scene files poperly... but thats beta.

SlithyToves
09-16-2010, 02:20 PM
That's great :D!

gabe
09-16-2010, 03:06 PM
I have passed this onto our programmers so they can fix it.

Thanks!

gabe
09-16-2010, 03:09 PM
The latest version is 3.0.0.2.9, I still have 3.0.0.2.3;) just noticed that I too need to update. You can get the latest version at http://www.alice.org/3. I have noticed that the version on the Project Kenai page is not the latest, also all references to the Kenai page have been removed on the Alice 3 page.

Hope this helps!

Yeah, I haven't been updating the Kenai page since we've been coming out with new releases fairly often. But I can update Kenai. Seems like a smart thing to do. :)

SlithyToves
09-16-2010, 03:14 PM
Does anybody know what is new in 3.0.0.2.9? Updating takes incredibly long so I don't want to download minor revisions (bug fixes, etc.) unless I have had a really big problem with the old version.

Gabe, you might want to know that the online installer (3.0.0.2.1) didn't update everything when I have previously tried to update. I had to uninstall everything and then reinstall the new version. When I tried to use the offline installer (3.0.0.2.3) it didn't work.