PDA

View Full Version : Unable to make lists


empire roman
10-04-2010, 09:35 AM
Hello all,

I am a student in a course using alice 2.2. I am trying to make a first person game (go figure) :).

However, I am loath to use multiple events to call a single method over again for multiple objects. So I searched on the forums and found a program (attachment titled skelebugs) someone had designed that had the ability that I was looking for, however my program (attachment called final project) is not letting me use the object under mouse expression, or letting me call objects in the tombstone list. In short, it is not letting me use the idea that he had to call one method for multiple objects.

Any insight or help would be appreciated.

thanks :)

x2495iiii
10-04-2010, 11:50 AM
You probably need to add on object parameter to your method, then when the parameter pops up in the event, change it from <None> to Object Under Mouse Cursor.

I'm taking a look at it...

Weird. That event is acting funny. I replaced it with an identical, working one and it worked.

By the way, you can get semi-realistic candle light for your game by using a spotlight placed just behind the candle and turned so that its beam hit the player's hand and the area just in front of the camera. I posted a screenshot below.

empire roman
10-05-2010, 08:50 AM
Hello, also found that the list I had made of the tombstone was calling itself onto the world level, and vice versa. and that is what was bugging the program also. ( it crashed yesterday lol ). So I am redesigning the entire thing. Thanks for the help, I tried did what you did and it worked out fine, must have been confused I guess.

Also thanks for the idea, did not even think about using a spotlight for the candlelight :D