PDA

View Full Version : Unable to create the gallery viewer


helpingteachers
08-10-2011, 10:38 AM
Hello We are using Alice 2.2 in a high school environment and this error happens every time you log on as a student.
Unable to create the gallery viewer.
Throwable that caused the error:
java.lang.NullPointerException
at edu.cmu.cs.stage3.alice.authoringtool.galleryviewe r.GalleryViewer.<init>(GalleryViewer.java:1073)
at edu.cmu.cs.stage3.alice.authoringtool.editors.scen eeditor.CameraViewPanel.guiInit(CameraViewPanel.ja va:782)
at edu.cmu.cs.stage3.alice.authoringtool.editors.scen eeditor.CameraViewPanel.<init>(CameraViewPanel.java:755)
at edu.cmu.cs.stage3.alice.authoringtool.editors.scen eeditor.SceneEditor.<init>(SceneEditor.java:355)
at edu.cmu.cs.stage3.alice.authoringtool.JAliceFrame. guiInit(JAliceFrame.java:160)
at edu.cmu.cs.stage3.alice.authoringtool.JAliceFrame.<init>(JAliceFrame.java:74)
at edu.cmu.cs.stage3.alice.authoringtool.AuthoringToo l.mainInit(AuthoringTool.java:453)
at edu.cmu.cs.stage3.alice.authoringtool.AuthoringToo l.<init>(AuthoringTool.java:403)
at edu.cmu.cs.stage3.alice.authoringtool.JAlice.main( JAlice.java:145)

aikmin
08-10-2011, 10:50 PM
It looks like you do not have permission to create your cache directory for the gallery, but i still don't see how you can get a null pointer at that line. Please make sure your students have write access to their user directory .alice2 folder.

By the way, what Alice version and release date are you using?

helpingteachers
08-11-2011, 08:51 AM
Thanks for the suggestion. We are using Alice 2.2. I did give a student test account permissions and then tried it again and still same error message. Thanks

aikmin
08-11-2011, 10:06 PM
Is Alice working with your administrator account? If it is working, then there is not problem with your Alice 2.2, otherwise there must be missing files and maybe that is causing the problem.

If everything is working on your admin account, then check to make sure students have permission to the following:
Alice directory and its sub folder C:\...\Alice2.2\Required\..
Alice home directory C:\...\.alice2
User home directory C:\...\username\(Desktop, My Documents, etc.)

I think the problem is that Alice is not able to find the required files or create temporary files (probably due to lack of permission to access those items or locations).

helpingteachers
08-12-2011, 01:19 PM
Hello, Thanks for the suggestion. I gave the user full control and still no luck. Thanks

helpingteachers
08-16-2011, 07:05 AM
Does anyone have any suggestions. Thanks