PDA

View Full Version : Glitch during fixing a bug, then critical saving error


GameKid
11-08-2011, 11:45 PM
First, I was fixing a bug in snack defender that if you click a beetle more than once, it keeps smashing itself, when for some reason it wouldn't let me put a boolean in an if/else statement. I tried quitting and saving, but then this happened.
An error has occurred while attempting to save your world.
This is a critical situation that needs to be dealt with immediately.

NOTE: Please check for a directory co-located with
your world named "Backups of <YourWorldNameHere>" which
should contain previously saved versions of your world.

We at the Alice Team apologize for any work you have lost

Please accept our sincerest apologies. The Alice Team.




Alice version: 2.2 02/10/2011



Throwable that caused the error:

java.lang.RuntimeException: Could not find ancestor: world, class: class edu.cmu.cs.stage3.alice.core.World
Key:
Details: x class edu.cmu.cs.stage3.alice.core.Variable


at edu.cmu.cs.stage3.alice.core.Element.internalGetKe y(Element.java:776)

at edu.cmu.cs.stage3.alice.core.Element.getKey(Elemen t.java:791)

at edu.cmu.cs.stage3.alice.core.reference.DefaultRefe renceGenerator.generateReference(DefaultReferenceG enerator.java:39)

at edu.cmu.cs.stage3.alice.core.Property.encodeRefere nce(Property.java:651)

at edu.cmu.cs.stage3.alice.core.property.ObjectArrayP roperty.encodeObject(ObjectArrayProperty.java:155)

at edu.cmu.cs.stage3.alice.core.Property.encode(Prope rty.java:683)

at edu.cmu.cs.stage3.alice.core.Element.internalStore (Element.java:1670)

at edu.cmu.cs.stage3.alice.core.Element.internalStore (Element.java:1722)

at edu.cmu.cs.stage3.alice.core.Element.store(Element .java:1768)

at edu.cmu.cs.stage3.alice.core.Element.store(Element .java:1781)

at edu.cmu.cs.stage3.alice.core.Element.store(Element .java:1784)

at edu.cmu.cs.stage3.alice.core.Element.store(Element .java:1816)

at edu.cmu.cs.stage3.alice.authoringtool.dialog.Store ElementProgressPane.construct(StoreElementProgress Pane.java:42)

at edu.cmu.cs.stage3.progress.ProgressPane$2.run(Prog ressPane.java:84)

at java.lang.Thread.run(Unknown Source)


I worked on fixing that glitch for nearly an hour. Could anybody tell me why that happened, what I should do, and how to avoid the error?

Mr Kidnapper
11-09-2011, 02:19 AM
Check your variable properties. One of them is probably blank or points to something that no longer exists.

GameKid
11-09-2011, 07:50 PM
Okay..... That makes sense. It was probably the military radio I was implementing that mysteriously dissapeared from the object list, but still existed in the world. It happened because I ignored the glitch and simply replaced the radio, with a radio with the excact same name.
So that's it. The military radio got glitched out and deleted, still thinking it's existing, when I add another with the same name and point to it in a method.
Wow. That was suprisingly simple, although I still think it's odd that the boolean function glitched out.
Thank you.