PDA

View Full Version : Java - Which Version is Compatible with Alice 2.2?


yammie1122
04-12-2012, 11:06 AM
Which version of Java should we be running on our computer to be compatible with Alice 2.2?

I am receiving Java errors when performing exercises from Chapter 8 & 9 of my book, so I have no way to verify if my programs are working properly.

I have tried 3 different computers (2 - Windows 7, 1 - Windows Vista). I've downloaded the latest Java 1.6.0_31 but still receive the Java errors. I've also tried using it with older versions of Java from 1.5.0_22, 1.6.0_16, 1.6.0_24, and 1.6.0_24, but still no good. I have already rebooted these machines several times, verified that the latest Java 1.6.0_31 is enabled, and cleared out my Java cache, but still no good.

I attached the Java error to this thread, so you can see the exact error I'm receiving.

Any help would be greatly appreciated.

aikmin
04-12-2012, 07:21 PM
Alice uses the JRE in its own Required folder, so updating your computer's JRE does nothing to help with the problem. By the way, the bug was not caused by Java or Alice. It looks like you have a null value in your program. It will be helpful if you can attach your program here so we can help determine the problem. You should also update your Alice 2.2.

yammie1122
04-12-2012, 08:20 PM
I've received null exception errors on other programs but this was different then the typical null exception error. The program is to use list variables to have 4 characters perform the wave. I have tried all 3 latest Alice 2.2b (Mar 12, Dec 11, and Aug 11) releases and receive the same error in all three.

Mr Kidnapper
04-22-2012, 03:42 AM
Congratulations. This is an actual bug. Objects from parameters apparently return as null in Alice regardless of the subpart you list. Not sure if it's just for roll though. I didn't test it.