PDA

View Full Version : Alice code stops working when I add new code!


DamonDragon13
09-29-2012, 05:29 AM
I have been working on a game recently and the game is getting very big. It is based in a small town, with people, moving windmills, LOTS of collision detection and my file says over 7000 3D objects. There are a whole lot of methods, over 40 for sure, and now I think when I add new chunks of code, other code behins to stop working. I have a method that lets the playable character shoot a bolt of lightning out of his hand but I added more code, and it started to mess up. The lightning wouldn't appear. Then I added more code after I fixed it, and it messed up again. Now nothing happens at all. The one button should make two attacks, depending on the mode you are in (High and Low profile. Like assassins creed) and none of them do anything now. It's not just that that has messed up but a lot more methods have messed up as well, to the point of not even letting me open the world, and making me search and one by one disable methods to see which one it is.

I cannot put a link to my Alice world on here because it is way to big to fit, I have tried.

Any help would be appreciated.

djslater107
09-30-2012, 05:34 AM
You are correct that there are limits to the numbers of models and the complexity of the worlds that one can build with Alice. Your game sounds very impressed, but I am not surprised that given 700 models + and all you are trying to do that Alice is starting to bog down.

I do not know that there is really a lot more that can be done. You may try and delete some models that you are only scenery and not essential to game play, but there is not very much more that can be done, I am afraid.

Sounds like a great world!

DamonDragon13
10-02-2012, 06:46 AM
Thank you, this helps me a lot. It is the best world I have made so far and I am very proud of it. A lot of work has gone into it and lately it has been letting me down with the code mishaps, but it's my own fault.

Thanks again. :)