PDA

View Full Version : Unable to run alice 2.3 (again)


mat9999
11-08-2012, 06:44 PM
My Alice 2.3 starts, but hangs on loading... It runs on Win XP, SP3, Core2Duo, 2GHz, 3GBRAM, 1280x720 resolution screen, Java 6.31. I must end the process in task manager.

Do someone have some suggestion what to do?

Thanks.

djslater107
11-09-2012, 07:26 AM
Would you do me a favor, delete the version of Alice that you have on your machine that you are trying to run and download an earlier version of Alice, to see if it will install and run. Try the August 5 version, available at this linků

http://www.alice.org/index.php?page=downloads/alice2.2_archive

Thank you,
Don

mat9999
11-09-2012, 03:55 PM
So, as you've already know I downloaded recommended version from august, I remove .alice folder, I deinstalled 3.1, cleared the registry and folders and tryed to run 2.3 on 4 PC (3 stacionary and 1 laptop). They all had XP SP3, slightly different resolution, 3 of them core2duo and laptop with dual core. The situation is the same everywere. But Alice 2.2 works. Now I have only 2 reason remain: 1. national settings or 2. bad copy of 2.3 . Or... ?

I'd like to figure out who had had the same problem, and because of this replaced 2.3 with 2.2? This might be good to know, to find the reason faster.

Thanks.

djslater107
11-10-2012, 08:55 AM
This may be a 32/64 bit operating system problem. Our JOGL libraries are for 32bit system, so all 64 bit users need to make their Alice open in 32bit. There is a setting in the properties to do this (for both MAC and Windows)

mat9999
11-10-2012, 11:25 AM
http://www.pugetsystems.com/blog/2011/01/13/windows-7-64-bit-running-32-bit-applications/

mat9999
11-11-2012, 12:50 PM
Return to my main problem I discovered, that 2.3 doesn't work on Vista as well.

twachi
11-13-2012, 04:58 AM
I can't start Alice 2.3 on Windows XP too.
So I try to run in command line and it show this exception message:


java.lang.NoClassDefFoundError: Could not initialize class edu.cmu.cs.stage3.alice.scenegraph.renderer.direct x7renderer.Renderer
at sun.reflect.NativeConstructorAccessorImpl.newInsta nce0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInsta nce(NativeConstructorAccessorImpl.java:39)
at sun.reflect.DelegatingConstructorAccessorImpl.newI nstance(DelegatingConstructorAccessorImpl.java:27)
at java.lang.reflect.Constructor.newInstance(Construc tor.java:513)
at java.lang.Class.newInstance0(Class.java:355)
at java.lang.Class.newInstance(Class.java:308)
at edu.cmu.cs.stage3.alice.scenegraph.renderer.Defaul tRenderTargetFactory.getRenderer(DefaultRenderTarg etFactory.java:85)
at edu.cmu.cs.stage3.alice.scenegraph.renderer.Defaul tRenderTargetFactory.setIsSoftwareEmulationForced( DefaultRenderTargetFactory.java:79)
at edu.cmu.cs.stage3.alice.authoringtool.AuthoringToo l.getRenderTargetFactory(AuthoringTool.java:990)
at edu.cmu.cs.stage3.alice.authoringtool.editors.scen eeditor.CameraViewPanel.renderInit(CameraViewPanel .java:872)
at edu.cmu.cs.stage3.alice.authoringtool.editors.scen eeditor.SceneEditor.setAuthoringTool(SceneEditor.j ava:238)
at edu.cmu.cs.stage3.alice.authoringtool.JAliceFrame. guiInit(JAliceFrame.java:176)
at edu.cmu.cs.stage3.alice.authoringtool.JAliceFrame.<init>(JAliceFrame.java:87)
at edu.cmu.cs.stage3.alice.authoringtool.AuthoringToo l.mainInit(AuthoringTool.java:461)
at edu.cmu.cs.stage3.alice.authoringtool.AuthoringToo l.<init>(AuthoringTool.java:411)
at edu.cmu.cs.stage3.alice.authoringtool.JAlice.main( JAlice.java:138)
java.lang.NullPointerException
at edu.cmu.cs.stage3.alice.scenegraph.renderer.Defaul tRenderTargetFactory.setIsSoftwareEmulationForced( DefaultRenderTargetFactory.java:79)
at edu.cmu.cs.stage3.alice.authoringtool.AuthoringToo l.getRenderTargetFactory(AuthoringTool.java:990)
at edu.cmu.cs.stage3.alice.authoringtool.editors.scen eeditor.CameraViewPanel.renderInit(CameraViewPanel .java:872)
at edu.cmu.cs.stage3.alice.authoringtool.editors.scen eeditor.SceneEditor.setAuthoringTool(SceneEditor.j ava:238)
at edu.cmu.cs.stage3.alice.authoringtool.JAliceFrame. guiInit(JAliceFrame.java:176)
at edu.cmu.cs.stage3.alice.authoringtool.JAliceFrame.<init>(JAliceFrame.java:87)
at edu.cmu.cs.stage3.alice.authoringtool.AuthoringToo l.mainInit(AuthoringTool.java:461)
at edu.cmu.cs.stage3.alice.authoringtool.AuthoringToo l.<init>(AuthoringTool.java:411)
at edu.cmu.cs.stage3.alice.authoringtool.JAlice.main( JAlice.java:138)


My windows was installed DirectX version 9.
What is DirectX version that Alice required?

djslater107
11-13-2012, 11:10 AM
Go to the Alice 2.x archive

http://www.alice.org/index.php?page=downloads/alice2.2_archive

download and install the 3/1/12 version. Alice creates an invisible .alice or .alice2 folder in your home directory. Delete that before running the older version.

mat9999
11-13-2012, 05:32 PM
Don, I need Alice 2.3, not 2.2.

twachi
11-13-2012, 11:22 PM
Yesterday, I cloud not start Alice 2.3 on my Windows XP.
Now I just found solution to start Alice 2.3

There are two files in folder "Alice 2.3\Required\lib".

1. jni_directx7renderer.dll is used for Windows 7.
2. jni_directx7renderer1.dll is used for Windows XP.

If you want to start Alice 2.3 on Windows XP

Just delete file "jni_directx7renderer.dll" or rename it to another name.
After that rename file "jni_directx7renderer1.dll" to "jni_directx7renderer.dll"

mat9999
11-14-2012, 06:11 PM
twachi, it works!

Thanks a lot.

m.

teatrubucuresti
11-26-2012, 10:28 AM
Try installing a newer version. It did the trick for me.

MrMoke
11-29-2012, 10:42 PM
This may be a 32/64 bit operating system problem. Our JOGL libraries are for 32bit system, so all 64 bit users need to make their Alice open in 32bit. There is a setting in the properties to do this (for both MAC and Windows)

At least not consistently anway. I have tried in several different workstations n my classroom, but it fails in some. Just stsrts and freezes at the splash screen.

Running 2.3 on a win7 64-bit machine at home, and works fine.

Are you sure it's not some security issiue?

MrMoke
11-29-2012, 10:46 PM
Try installing a newer version. It did the trick for me.



The 8/5/2012 version would appear to be the only version of 2.3

MrMoke
11-29-2012, 10:53 PM
This may be a 32/64 bit operating system problem. Our JOGL libraries are for 32bit system, so all 64 bit users need to make their Alice open in 32bit. There is a setting in the properties to do this (for both MAC and Windows)

And the process would be?

MrMoke
11-29-2012, 11:41 PM
Currently have two Alice 2.3 zip files.
One is 342,218KB
One is 341,511KB

djslater107
11-30-2012, 12:02 PM
Try this...

Sorry to hear that you are having trouble launching Alice 2.3 on your computer. Can you please try renaming the following file:
C:\...\Alice 2.3\Required\lib\win32\jni_directx7renderer1.dll to jni_directx7renderer.dll (just remove the 1 from the end) and remove the other one from the directory.

Run Alice 2.3 and see if that works. If not, try running Alice in "compatibility mode". Right click on Alice.exe and select properties. In the "Compatibility tab, check the Run this program in compatibility mode for: Windows XP" checkbox.

Keep us posted...

Thanks,
Don Slater

MrMoke
11-30-2012, 02:35 PM
Yesterday, I cloud not start Alice 2.3 on my Windows XP.
Now I just found solution to start Alice 2.3

There are two files in folder "Alice 2.3\Required\lib".

1. jni_directx7renderer.dll is used for Windows 7.
2. jni_directx7renderer1.dll is used for Windows XP.

If you want to start Alice 2.3 on Windows XP

Just delete file "jni_directx7renderer.dll" or rename it to another name.
After that rename file "jni_directx7renderer1.dll" to "jni_directx7renderer.dll"

OK- I renamed the Win7 version to jni_directx7renderer-old.dll, and changed the XP version to jni_directx7renderer.dll
It seems to be running on the 32-bit Win7 machine that it failed on yesterday.

Does this mean that the Win7 renderer is busted?

kevkevjames
07-22-2013, 12:17 AM
Splash screen on 2.3 is blank and frozen. The only way to get rid of it is to force quit. Uninstalled and reinstalled software, but get the same result. This happened after software crashed during programming. Method editor section blue screened, and start button turned gray.

Once I uninstalled 5/5/13 2.3, then installed 3/1/13 version, I was able to open the program once again.