PDA

View Full Version : NullPointerException loading world


wynn
02-17-2013, 02:50 PM
I am getting the following error loading my world:

Unable to load world


Alice version: 2.3
os.name: Mac OS X
os.version: 10.7.5
os.arch: x86_64
java.vm.name: Java HotSpot(TM) 64-Bit Server VM
java.vm.version: 20.12-b01-434
user.dir: /Applications/Alice.app/Contents/Required

Throwable that caused the error:
java.lang.NullPointerException
at edu.cmu.cs.stage3.alice.core.visualization.ModelVi sualization.loadCompleted(ModelVisualization.java: 51)
at edu.cmu.cs.stage3.alice.core.Element.loadCompleted (Element.java:1429)
at edu.cmu.cs.stage3.alice.core.Element.load(Element. java:1559)
at edu.cmu.cs.stage3.alice.authoringtool.dialog.LoadE lementProgressPane.construct(LoadElementProgressPa ne.java:42)
at edu.cmu.cs.stage3.progress.ProgressPane$2.run(Prog ressPane.java:86)
at java.lang.Thread.run(Thread.java:680)


Unfortunately, I cannot attach the world because its size is 26 MB and the upload limit is apparently 20 MB.

Alice also can't load any of the backups of my world.

Help?

Wynn

djslater107
02-18-2013, 07:00 AM
See this link...

http://help.alice.org/w/page/59015096/Alice%202_3%20FAQ#BrokeA2W

This is a bit technical, but without having access to your world, this is the next best thing.

Good luck!

Don Slater

wynn
02-18-2013, 08:57 AM
Thanks for the help. I'll see what I can do.

wynn
02-20-2013, 01:13 PM
I was able to shrink the size of the world to under 20 MB to fit in your upload limits by replacing some of the object textures (texture/image.png) with smaller versions of the same. This world dies with the same error as the original world (NullPointerException), so hopefully I haven't messed anything else up. See attached world. Thanks for any help.

djslater107
02-22-2013, 07:39 AM
I have sent this file to support to see what can be done with it...

It has an exceptionally large number of models in it, which can cause problems for Alice as the size of the world approaches the allocated stack space in the system for the program.

May I ask, did you use the clone tool in the scene editor to create all the models, or did you add each object individually? The clone tool was designed for scene decoration and can sometimes save space when using lots of objects. (It does have limitations, and can cause problems when you try and animate any of the cloned objects.)

Finally, with my students I recommend that they build the basic structure of their world, with a minimal amount of scenery to start, get their animation working, and then start layering in the additional scenery, saving frequently, and with different version numbers, so that if and when they encounter the problem you seem to be experiencing, they can go back to an earlier version.

I will let you know if an when I hear anything.

wynn
02-22-2013, 05:06 PM
I did use the clone tool when making multiple copies of my objects and thanks for letting me know about making the animations before adding scenery. I hope you can find a solution and I will try to be more aware of problems like this.

aikmin
02-25-2013, 08:58 PM
I removed one of your object visualization model. Alice is giving you that null pointer exception because you had deleted the Item variable from the model.

wynn
02-26-2013, 06:06 PM
My alice world successfully loaded, and I can see witch object was deleted.
Thanks for the help, and I hope you can help in the future.