Alice Community

Alice Community (http://www.alice.org/community/index.php)
-   Bugs and Troubleshooting (http://www.alice.org/community/forumdisplay.php?f=18)
-   -   Window 7 problems v2.2 (http://www.alice.org/community/showthread.php?t=4090)

pearcej 03-17-2010 07:19 PM

Window 7 problems v2.2
 
Others have reported Alice 2.2 "hanging" following the splash screen.
I am having seemingly related but different problems after upgrading my laptop to Windows 7.

Most of the time Alice "hangs" following the splash screen, but very occasionally it actually opens and runs.

On the rare occasion that it does open, worlds are not running correctly. For example, in the FlightSimulator example seems to run fine until about the second ring. Then I get a crash followed by:
Alice version: 2.2 8/1/2009

*****Running World*****
*****Stopping World*****
*****Running World*****
Exception in thread "JMF thread: com.sun.media.PlaybackEngine@62bba7 ( prefetchThread)" java.lang.IllegalArgumentException: Requested value 7.9588003 exceeds allowable maximum value 6.0206.
at javax.sound.sampled.FloatControl.setValue(Unknown Source)
at com.sun.media.sound.DirectAudioDevice$DirectDL$Gain.setValue(Unknown Source)
at com.sun.media.renderer.audio.device.JavaSoundOutput.setGain(JavaSoundOutput.java:157)
at com.sun.media.renderer.audio.AudioRenderer.initDevice(AudioRenderer.java:294)
at com.sun.media.renderer.audio.JavaSoundRenderer.initDevice(JavaSoundRenderer.java:125)
at com.sun.media.renderer.audio.JavaSoundRenderer.open(JavaSoundRenderer.java:91)
at com.sun.media.BasicRendererModule.doPrefetch(BasicRendererModule.java:157)
at com.sun.media.BasicTrackControl.prefetchTrack(BasicTrackControl.java:98)
at com.sun.media.PlaybackEngine.doPrefetch1(PlaybackEngine.java:592)
at com.sun.media.PlaybackEngine.doPrefetch(PlaybackEngine.java:547)
at com.sun.media.PrefetchWorkThread.process(BasicController.java:1430)
at com.sun.media.StateTransitionWorkThread.run(BasicController.java:1339)

This error is reproducible and always occurs at the same point even after a reboot. Similar crashes happen with other worlds which I know to be fine.

Several of my friends are natively running Alice 2.2 in Windows 7 (32 bit) without difficulty. In fact, I have it running natively on an older laptop with no problems.

Here are the things I have tried without success:
- Rebooting.
- Downloading again and rebooting.
- Copying the entire Alice 2.2 folder which is running fine on my other Windows 7 computer.
- Running as an administrator.
- Reducing my local UAC security settings to none.
- Changing to emulation mode with XP SP2.
- Changing to emulation mode with XP SP3.

None of these things seem to do any good.

Worse, I cannot predict when Alice might open and when it might hang--it seems random.

I really have no idea what to try next. My version of Java is 1.6.0_18 if that might be the culprit.

Has anyone figured out what to do to fix these problems with Windows 7?
Any help would be very greatly appreciated.

King Gamer(gorit) 03-18-2010 02:40 PM

It is your system windows 7 is actually the least glitchy os for me.

pearcej 03-19-2010 03:09 AM

Alice 2.2 inconsistent in Windows 7
 
Thanks for your reply.

I am really liking the Windows 7 OS except for these weird problems I am having with Alice 2.2. I am a college professor in a Math/CS department, and I am using Alice in one of the courses I am teaching this term. My college is planning a campus wide OS upgrade to Windows 7 of all student laptops in the fall, so I was asked to test the new OS out this term.

Because of this, I installed Windows 7 on a loaner laptop and tested Alice 2.2. It and all my other departmental software worked fine, so I decided to upgrade my primary laptop to Windows 7. Now I am experiencing these weird problems.

In some ways, I am glad that I am experiencing these problems because I hope to be able to figure this out before our students are subjected to these problems in the Fall. On the other hand, it is a somewhat of a problem for me this term... I can't really use Alice 2.0 when my students are using 2.2... And if I don't figure this out, students will have these problems in the Fall.

Furthermore, I am baffled why Alice 2.2 runs fine all the time in some Windows 7 environments, but only occasionally fully opens in mine. More baffling still is why my installation occasionally runs fine, while most of the time (if it opens at all) generates Java errors with working worlds... And this is true with multiple reinstalls from multiple sources, including copying the Alice folder directly from a Windows 7 machine where Alice 2.2 is working fine.

jediaction 03-19-2010 08:29 AM

This happens becausae of the OS. When you upgrade your computer is not the old OS. Alice 2.2 was nto made specifically for Win7. LIke if you run an Alice 2.2 project on an Alice 2.0, it will get an error, so just to explain what king gamer said.

Niteshifter 03-19-2010 11:55 AM

Have you tried a mirror download? Sometimes files can get corrupted in the process of downloading because of the location.

Do you have a recovery CD for Windows 7? If so, you should try a low-level format (ie: zero-wiping, etc) and then reinstall Windows using the recovery CD. This is usually used as a last resort, but I've actually had several conflicts with other programs that didn't even exist when I switched operating systems. If you want a program to do low-level formatting, I would suggest using "Darik's Boot and Nuke".

King Gamer(gorit) 03-19-2010 02:47 PM

[QUOTE=Niteshifter;18712]Have you tried a mirror download? Sometimes files can get corrupted in the process of downloading because of the location.

Do you have a recovery CD for Windows 7? If so, you should try a low-level format (ie: zero-wiping, etc) and then reinstall Windows using the recovery CD. This is usually used as a last resort, but I've actually had several conflicts with other programs that didn't even exist when I switched operating systems. If you want a program to do low-level formatting, I would suggest using "Darik's Boot and Nuke".[/QUOTE]

Good point. This has hapened to me before and really makes me mad.

pearcej 03-19-2010 09:50 PM

[QUOTE=Niteshifter;18712]Have you tried a mirror download? Sometimes files can get corrupted in the process of downloading because of the location.

Do you have a recovery CD for Windows 7? If so, you should try a low-level format (ie: zero-wiping, etc) and then reinstall Windows using the recovery CD. This is usually used as a last resort, but I've actually had several conflicts with other programs that didn't even exist when I switched operating systems. If you want a program to do low-level formatting, I would suggest using "Darik's Boot and Nuke".[/QUOTE]

I really appreciate these suggestions.

I have now installed Alice 2.2 from a variety of locations... including copying the folder from my other Window 7 environment where Alice 2.2 is working fine. Some worked better than others (like once every 7-15 times or something,) but none work sufficiently well to be usable...

I upgraded my hard-drive at the same time as upgrading to Windows 7 (a week ago), so I doubt I need a reformat... However, I am indeed suspecting a software conflict... I have not installed very many programs at this point, so one would think that would narrow the issue down...

King Gamer(gorit) 03-20-2010 11:44 AM

Suggestion
 
I have an idea. Before you open alice open task manager and end all processes that are not necisary. It would eliminate the need to isolate the problem casusing program.

zonedabone 03-22-2010 08:26 PM

[URL]http://alice.org/community/showthread.php?t=3998[/URL]

About 1/2 way down it talks about problems with starting. Do it all, and weep!


All times are GMT -5. The time now is 09:15 PM.

Copyright ©2018, Carnegie Mellon University
Alice 2.x 1999-2012, Alice 3.x 2008-2012, Carnegie Mellon University. All rights reserved.