Thread: Compatability
View Single Post
Old
pausch
Director of the Alice Project
 
Status: Offline
Posts: 38
Join Date: Jul 2005
Default 03-14-2006, 09:40 AM

Currently, we do not have plans to make Alice v3.0 execute Alice v2.0 worlds.

Alice v2.0 essentially creates an "Alice run-time system" that interprets the alice language in an Alice virtual machine.

Alice v3.0 is being rewritten from scratch and will be "Java under the hood," meaning that your Alice program will "dump" a Java program that then executes in a Java virtual machine. With this great a difference, we do not plan to make Alice v3.0 "backward compatible"

Sorry about that.


Randy Pausch
Director of the Alice Project
   
Reply With Quote