View Single Post
Old
DrJim
Guest
 
Status:
Posts: n/a
Default 09-01-2008, 07:24 AM

Quote:
Originally Posted by toaster View Post
Will the scripts I create in 2.x migrate correctly to 3.0 or should I wait?
At one time the CMU position was that there would not be backward compatibility with objects. That would pretty much also mean that 2.x code wouldn't work without significant modification.

Maybe Gabe or someone can give an update as to whether this is still true.

As far as waiting goes - the earliest date I've seen for 3.0 is to start Beta testing in the spring of 2009 - so even by the most optomistic estimates, it's over a year away. (My own observation is that for software or any other complex projects - optomistic milestones are rarely met.) Thus it basically boils down to whether you are really interesed in learning OOP - in which case 3.0 is probably worth the wait - or whether you want to experiment with 3D worlds and animation. If the latter, 2.0 or Storytelling Alice might be of interest right now - and the basic principles of 3D, animation and programming functions are not going to change, even though the implementation details may. (Note: I may have missed that CMU is going to support string theory in 3.0 - but if so it's well over a year away. )

(I personally wouldn't recommend 2.2 Beta at this point - though it's library of "walking" characters is a nice addition to the 2.0 gallery and runs fine in that version.)
   
Reply With Quote