Alice Community  

Go Back   Alice Community > General Discussion > Questions and Comments

Reply
 
Thread Tools Display Modes
Really high cpu usage when 'idle'
Old
mflanagan
Junior Member
 
Status: Offline
Posts: 1
Join Date: Sep 2011
Default Really high cpu usage when 'idle' - 09-12-2011, 10:18 PM

Any ideas why Alice is using so much CPU even when it's just idle? All I have to do is start it, and after a few seconds the cpu usage on two cores is 25%...for an i5 that's a huge amount. The usage does NOT increase when I'm coding or running a world. Any ideas?

Thanks.

MikeF
   
Reply With Quote
Old
Mr Kidnapper
Senior Member
 
Status: Offline
Posts: 442
Join Date: Feb 2011
Default 09-14-2011, 11:24 PM

If I had to guess, it's because Alice is using up an entire core of your i5 (Quad core, right?) to render the 3d scene. It's actually the same for me, too. Alice has a CPU Usage never exceeding exactly 25% on my quad core Q6600. Even though I have a perfectly good monster GPU for it to use instead.
Edit: Nevermind. Alice's CPU usage is normal on mine. 0% on idle, only reaches 10% while working.

Last edited by Mr Kidnapper; 09-14-2011 at 11:28 PM.
   
Reply With Quote
Old
andyjin
Guest
 
Status:
Posts: n/a
Default 03-30-2012, 03:35 PM

I have the same issue on my Macbook Pro, i7/8G. I use 2.2b. My CPU usage is 90% when Alice is idle. I found out it is because the "JOGL" 3d rendering. I moved the "Java3D" and solved the problem.

Hope this help.
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Copyright ©2017, Carnegie Mellon University
Alice 2.x 1999-2012, Alice 3.x 2008-2012, Carnegie Mellon University. All rights reserved.