Alice Community  

Go Back   Alice Community > Alice 2 > Bugs and Troubleshooting

Reply
 
Thread Tools Display Modes
Old
mat9999
Junior Member
 
Status: Offline
Posts: 7
Join Date: Nov 2012
Location: Ljubljana
Default 11-14-2012, 06:11 PM

twachi, it works!

Thanks a lot.

m.
   
Reply With Quote
Unable to run alice 2.3 (again)
Old
teatrubucuresti
Junior Member
 
Status: Offline
Posts: 1
Join Date: Nov 2012
Default Unable to run alice 2.3 (again) - 11-26-2012, 10:28 AM

Try installing a newer version. It did the trick for me.

Last edited by x2495iiii; 09-06-2013 at 01:49 PM. Reason: Spam link removed
   
Reply With Quote
Doesn't seem to work in 32-bit Win7 either
Old
MrMoke
Senior Member
 
MrMoke's Avatar
 
Status: Offline
Posts: 500
Join Date: Sep 2007
Location: Austin, Texas
Default Doesn't seem to work in 32-bit Win7 either - 11-29-2012, 10:42 PM

Quote:
Originally Posted by djslater107 View Post
This may be a 32/64 bit operating system problem. Our JOGL libraries are for 32bit system, so all 64 bit users need to make their Alice open in 32bit. There is a setting in the properties to do this (for both MAC and Windows)
At least not consistently anway. I have tried in several different workstations n my classroom, but it fails in some. Just stsrts and freezes at the splash screen.

Running 2.3 on a win7 64-bit machine at home, and works fine.

Are you sure it's not some security issiue?
Attached Files
File Type: txt Alice2-3 is Broken Info.txt (883 Bytes, 2 views)

Last edited by MrMoke; 11-29-2012 at 10:52 PM.
   
Reply With Quote
What newer Version?
Old
MrMoke
Senior Member
 
MrMoke's Avatar
 
Status: Offline
Posts: 500
Join Date: Sep 2007
Location: Austin, Texas
Default What newer Version? - 11-29-2012, 10:46 PM

Quote:
Originally Posted by teatrubucuresti View Post
Try installing a newer version. It did the trick for me.
The 8/5/2012 version would appear to be the only version of 2.3

Last edited by x2495iiii; 09-06-2013 at 01:49 PM. Reason: Spam link removed
   
Reply With Quote
Old
MrMoke
Senior Member
 
MrMoke's Avatar
 
Status: Offline
Posts: 500
Join Date: Sep 2007
Location: Austin, Texas
Default 11-29-2012, 10:53 PM

Quote:
Originally Posted by djslater107 View Post
This may be a 32/64 bit operating system problem. Our JOGL libraries are for 32bit system, so all 64 bit users need to make their Alice open in 32bit. There is a setting in the properties to do this (for both MAC and Windows)
And the process would be?
   
Reply With Quote
Which One
Old
MrMoke
Senior Member
 
MrMoke's Avatar
 
Status: Offline
Posts: 500
Join Date: Sep 2007
Location: Austin, Texas
Default Which One - 11-29-2012, 11:41 PM

Currently have two Alice 2.3 zip files.
One is 342,218KB
One is 341,511KB
   
Reply With Quote
Alice 2.3
Old
djslater107
Administrator
 
Status: Offline
Posts: 145
Join Date: Jan 2007
Default Alice 2.3 - 11-30-2012, 12:02 PM

Try this...

Sorry to hear that you are having trouble launching Alice 2.3 on your computer. Can you please try renaming the following file:
C:\...\Alice 2.3\Required\lib\win32\jni_directx7renderer1.dll to jni_directx7renderer.dll (just remove the 1 from the end) and remove the other one from the directory.

Run Alice 2.3 and see if that works. If not, try running Alice in "compatibility mode". Right click on Alice.exe and select properties. In the "Compatibility tab, check the Run this program in compatibility mode for: Windows XP" checkbox.

Keep us posted...

Thanks,
Don Slater


Don Slater
Alice Team
Carnegie Mellon University
   
Reply With Quote
Old
MrMoke
Senior Member
 
MrMoke's Avatar
 
Status: Offline
Posts: 500
Join Date: Sep 2007
Location: Austin, Texas
Default 11-30-2012, 02:35 PM

Quote:
Originally Posted by twachi View Post
Yesterday, I cloud not start Alice 2.3 on my Windows XP.
Now I just found solution to start Alice 2.3

There are two files in folder "Alice 2.3\Required\lib".

1. jni_directx7renderer.dll is used for Windows 7.
2. jni_directx7renderer1.dll is used for Windows XP.

If you want to start Alice 2.3 on Windows XP

Just delete file "jni_directx7renderer.dll" or rename it to another name.
After that rename file "jni_directx7renderer1.dll" to "jni_directx7renderer.dll"
OK- I renamed the Win7 version to jni_directx7renderer-old.dll, and changed the XP version to jni_directx7renderer.dll
It seems to be running on the 32-bit Win7 machine that it failed on yesterday.

Does this mean that the Win7 renderer is busted?
   
Reply With Quote
Having the same problem on Mac OS X 10.8.4
Old
kevkevjames
Junior Member
 
Status: Offline
Posts: 1
Join Date: Jul 2013
Default Having the same problem on Mac OS X 10.8.4 - 07-22-2013, 12:17 AM

Splash screen on 2.3 is blank and frozen. The only way to get rid of it is to force quit. Uninstalled and reinstalled software, but get the same result. This happened after software crashed during programming. Method editor section blue screened, and start button turned gray.

Once I uninstalled 5/5/13 2.3, then installed 3/1/13 version, I was able to open the program once again.

Last edited by kevkevjames; 07-22-2013 at 12:54 AM.
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Copyright ©2017, Carnegie Mellon University
Alice 2.x 1999-2012, Alice 3.x 2008-2012, Carnegie Mellon University. All rights reserved.