Alice Community  

Go Back   Alice Community > Alice 2 > Bugs and Troubleshooting

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Problem removing item from the end of a list.
Old
DrJim
Guest
 
Status:
Posts: n/a
Question Problem removing item from the end of a list. - 02-22-2007, 02:37 PM

I have a problem using the “remove item from end of <list>“ command - when I try to use it, I always get an error message. The message is similar to that I get when I try to remove something from a list and what I’m trying to remove isn’t there - but it seems like there should always be an item at the end of the list unless the list is completely empty.

The attached world illustrates the problem. As set up, it works fine - the bunny moves from cone to cone around a circle, going to one less cone each loop.

However if I substitute “remove item from end ...” for “remove item from position ...” I get an error - even though these should be equivalent commands. Looks to me like this is a real bug - anyone see anything I’m missing?
Attached Files
File Type: a2w List Test.a2w (347.2 KB, 569 views)
   
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Copyright ©2018, Carnegie Mellon University
Alice 2.x © 1999-2012, Alice 3.x © 2008-2012, Carnegie Mellon University. All rights reserved.