Alice Community  

Go Back   Alice Community > Alice 3 > How Do I?

Reply
 
Thread Tools Display Modes
Old
MiR
Guest
 
Status:
Posts: n/a
Default 09-16-2010, 12:09 PM

OK, thanks for the tip.
I know this is not the technical help page, but...
I upgraded from 3.0.0.0.64 to 3.0.0.2.9 and now Alice won't start anymore...

I would appreciate any help, as this is very unusual for me...

My System: Ubuntu 9.10
Error: Unable to load OpenGL
Output from the console:

Code:
version: 3.0.0.2.9
comboBoxUI: javax.swing.plaf.synth.SynthComboBoxUI@1694eca 
comboBoxUI: javax.swing.plaf.synth.SynthComboBoxUI@1fb050c 
setLocale en_US 
java.util.Locale.getDefault() de_DE 
javax.swing.JComponent.getDefaultLocale() de_DE 
platform: Linux-i386 
library path: /host/data/Alice3/Alice3Beta/application/linux-i586 

UNABLE TO LOAD OPENGL 
------ -- ---- ------ 
The most common reason for this is an incorrectly set Java library path.  Please update your VM arguments. 
The text below has been copied to the clipboard for your convenience. 
Linux-i386 

all properties 
--- ---------- 
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<!DOCTYPE properties SYSTEM "http://java.sun.com/dtd/properties.dtd">
<properties>
<comment>comment</comment>
<entry key="java.runtime.name">Java(TM) SE Runtime Environment</entry>
<entry key="sun.boot.library.path">/usr/lib/jvm/java-6-sun-1.6.0.20/jre/lib/i386</entry>
<entry key="java.vm.version">16.3-b01</entry>
<entry key="java.vm.vendor">Sun Microsystems Inc.</entry>
<entry key="java.vendor.url">http://java.sun.com/</entry>
<entry key="path.separator">:</entry>
<entry key="java.vm.name">Java HotSpot(TM) Server VM</entry>
<entry key="file.encoding.pkg">sun.io</entry>
<entry key="sun.java.launcher">SUN_STANDARD</entry>
<entry key="user.country">DE</entry>
<entry key="sun.os.patch.level">unknown</entry>
<entry key="java.vm.specification.name">Java Virtual Machine Specification</entry>
<entry key="user.dir">/host/data/Alice3/Alice3Beta</entry>
<entry key="java.runtime.version">1.6.0_20-b02</entry>
<entry key="java.awt.graphicsenv">sun.awt.X11GraphicsEnvironment</entry>
<entry key="java.endorsed.dirs">/usr/lib/jvm/java-6-sun-1.6.0.20/jre/lib/endorsed</entry>
<entry key="os.arch">i386</entry>
<entry key="java.io.tmpdir">/tmp</entry>
<entry key="line.separator">
</entry>
<entry key="java.vm.specification.vendor">Sun Microsystems Inc.</entry>
<entry key="os.name">Linux</entry>
<entry key="sun.jnu.encoding">UTF-8</entry>
<entry key="java.library.path">/host/data/Alice3/Alice3Beta/application/linux-i586</entry>
<entry key="java.specification.name">Java Platform API Specification</entry>
<entry key="java.class.version">50.0</entry>
<entry key="sun.management.compiler">HotSpot Tiered Compilers</entry>
<entry key="os.version">2.6.31-22-generic</entry>
<entry key="user.home">/home/mir</entry>
<entry key="user.timezone"/>
<entry key="java.awt.printerjob">sun.print.PSPrinterJob</entry>
<entry key="file.encoding">UTF-8</entry>
<entry key="java.specification.version">1.6</entry>
<entry key="java.class.path">/host/data/Alice3/Alice3Beta/ext/apple/AppleJavaExtensions.jar:/host/data/Alice3/Alice3Beta/ext/jaf/activation.jar:/host/data/Alice3/Alice3Beta/ext/jira/jira-soapclient-4.0-with-dependencies.jar:/host/data/Alice3/Alice3Beta/ext/jmf/JMF-2.1.1e/lib/customizer.jar:/host/data/Alice3/Alice3Beta/ext/jmf/JMF-2.1.1e/lib/jmf.jar:/host/data/Alice3/Alice3Beta/ext/jmf/JMF-2.1.1e/lib/mediaplayer.jar:/host/data/Alice3/Alice3Beta/ext/jmf/JMF-2.1.1e/lib/multiplayer.jar:/host/data/Alice3/Alice3Beta/ext/jmfmp3/lib/ext/mp3plugin.jar:/host/data/Alice3/Alice3Beta/ext/jogl/lib/gluegen-rt.jar:/host/data/Alice3/Alice3Beta/ext/jogl/lib/jogl.jar:/host/data/Alice3/Alice3Beta/ext/mail/lib/dsn.jar:/host/data/Alice3/Alice3Beta/ext/mail/lib/imap.jar:/host/data/Alice3/Alice3Beta/ext/mail/lib/mailapi.jar:/host/data/Alice3/Alice3Beta/ext/mail/lib/pop3.jar:/host/data/Alice3/Alice3Beta/ext/mail/lib/smtp.jar:/host/data/Alice3/Alice3Beta/ext/mail/mail.jar:/host/data/Alice3/Alice3Beta/ext/modified_nimbus/modified_nimbus.jar:/host/data/Alice3/Alice3Beta/ext/rpc/xmlrpc-client-1.1.jar:/host/data/Alice3/Alice3Beta/ext/swingworker/swing-worker-1.2.jar:/host/data/Alice3/Alice3Beta/ext/wrapped_flow_layout/wrapped_flow_layout.jar:/host/data/Alice3/Alice3Beta/ext/youtube/google-collect-1.0-rc1.jar:/host/data/Alice3/Alice3Beta/ext/youtube/youtube.jar:/host/data/Alice3/Alice3Beta/gallery/mtwtGalleryBoxes.jar:/host/data/Alice3/Alice3Beta/gallery/mtwtGalleryLargeIcons.jar:/host/data/Alice3/Alice3Beta/gallery/stagePersonEditorLargeIcons.jar:/host/data/Alice3/Alice3Beta/lib/3.0.0.2.9/alicecore.jar</entry>
<entry key="user.name">mir</entry>
<entry key="org.alice.ide.IDE.install.dir">/host/data/Alice3/Alice3Beta</entry>
<entry key="java.vm.specification.version">1.0</entry>
<entry key="java.home">/usr/lib/jvm/java-6-sun-1.6.0.20/jre</entry>
<entry key="sun.arch.data.model">32</entry>
<entry key="user.language">de</entry>
<entry key="java.specification.vendor">Sun Microsystems Inc.</entry>
<entry key="java.vm.info">mixed mode</entry>
<entry key="java.version">1.6.0_20</entry>
<entry key="java.ext.dirs">/usr/lib/jvm/java-6-sun-1.6.0.20/jre/lib/ext:/usr/java/packages/lib/ext</entry>
<entry key="sun.boot.class.path">/usr/lib/jvm/java-6-sun-1.6.0.20/jre/lib/resources.jar:/usr/lib/jvm/java-6-sun-1.6.0.20/jre/lib/rt.jar:/usr/lib/jvm/java-6-sun-1.6.0.20/jre/lib/sunrsasign.jar:/usr/lib/jvm/java-6-sun-1.6.0.20/jre/lib/jsse.jar:/usr/lib/jvm/java-6-sun-1.6.0.20/jre/lib/jce.jar:/usr/lib/jvm/java-6-sun-1.6.0.20/jre/lib/charsets.jar:/usr/lib/jvm/java-6-sun-1.6.0.20/jre/classes</entry>
<entry key="java.vendor">Sun Microsystems Inc.</entry>
<entry key="swing.aatext">true</entry>
<entry key="file.separator">/</entry>
<entry key="java.vendor.url.bug">http://java.sun.com/cgi-bin/bugreport.cgi</entry>
<entry key="sun.io.unicode.encoding">UnicodeLittle</entry>
<entry key="sun.cpu.endian">little</entry>
<entry key="sun.desktop">gnome</entry>
<entry key="sun.cpu.isalist"/>
</properties>
Possibly, the jogl library module .so for linux-i586 is missing? At least I found no trace in the subdirs of my install...

Last edited by MiR; 09-16-2010 at 12:42 PM.
   
Reply With Quote
Old
SlithyToves
Member
 
SlithyToves's Avatar
 
Status: Offline
Posts: 20
Join Date: Sep 2010
Location: USA
Default 09-16-2010, 01:12 PM

I feel so bad for you! I figured that newer is better, which, apparently, is not true, at least not in your case. I am not an expert at this kind of thing, so I can't really help. You might want to post your problem at the Bugs and Troubleshooting forum (http://www.alice.org/community/forumdisplay.php?f=18), where somebody who knows something might be able to help you.


SlithyToves

"Twas brillig, and the slithy toves
Did gyre and gimble in the wabe"
   
Reply With Quote
Old
MiR
Guest
 
Status:
Posts: n/a
Default 09-16-2010, 01:50 PM

No problem, I sorted this bug out.
The 0.29 package did not contain the so libraries for linux-i586.
After downloading an older package and extracting the libs from there, Alice started normaly.
It just failed to import older scene files poperly... but thats beta.
   
Reply With Quote
Old
SlithyToves
Member
 
SlithyToves's Avatar
 
Status: Offline
Posts: 20
Join Date: Sep 2010
Location: USA
Default 09-16-2010, 03:20 PM

That's great !


SlithyToves

"Twas brillig, and the slithy toves
Did gyre and gimble in the wabe"
   
Reply With Quote
Old
gabe
Administrator
 
gabe's Avatar
 
Status: Offline
Posts: 461
Join Date: Jul 2005
Location: Pittsburgh, PA
Default 09-16-2010, 04:06 PM

I have passed this onto our programmers so they can fix it.

Thanks!
   
Reply With Quote
Old
gabe
Administrator
 
gabe's Avatar
 
Status: Offline
Posts: 461
Join Date: Jul 2005
Location: Pittsburgh, PA
Default 09-16-2010, 04:09 PM

Quote:
Originally Posted by SlithyToves View Post
The latest version is 3.0.0.2.9, I still have 3.0.0.2.3 just noticed that I too need to update. You can get the latest version at http://www.alice.org/3. I have noticed that the version on the Project Kenai page is not the latest, also all references to the Kenai page have been removed on the Alice 3 page.

Hope this helps!
Yeah, I haven't been updating the Kenai page since we've been coming out with new releases fairly often. But I can update Kenai. Seems like a smart thing to do.
   
Reply With Quote
Old
SlithyToves
Member
 
SlithyToves's Avatar
 
Status: Offline
Posts: 20
Join Date: Sep 2010
Location: USA
Default 09-16-2010, 04:14 PM

Does anybody know what is new in 3.0.0.2.9? Updating takes incredibly long so I don't want to download minor revisions (bug fixes, etc.) unless I have had a really big problem with the old version.

Gabe, you might want to know that the online installer (3.0.0.2.1) didn't update everything when I have previously tried to update. I had to uninstall everything and then reinstall the new version. When I tried to use the offline installer (3.0.0.2.3) it didn't work.


SlithyToves

"Twas brillig, and the slithy toves
Did gyre and gimble in the wabe"

Last edited by SlithyToves; 09-16-2010 at 04:19 PM.
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Copyright ©2018, Carnegie Mellon University
Alice 2.x 1999-2012, Alice 3.x 2008-2012, Carnegie Mellon University. All rights reserved.