Alice Community  

Go Back   Alice Community > Alice 2 > Bugs and Troubleshooting

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Alice 2.2 only launches under one profile on a Mac
Old
shnew
Guest
 
Status:
Posts: n/a
Default Alice 2.2 only launches under one profile on a Mac - 07-10-2010, 12:54 PM

I installed Alice 2.2 yesterday on my Mac (OSX 10.5.8, 1.67 GHz PPC G4, with 2 GB RAM) while in my admin profile (which I only use for installing/updating programs). Program launched with no difficulties, and I was able to use one of the tutorials. However, after logging in under my back up admin profile, Alice starts to load, then closes (before reaching the splash screen). The same problem occurs when under my normal user profile.

I redownloaded the application & reinstalled. No change in behavior. Console shows the following:

7/10/10 Jul 10, 2010 12:09:55 [0x0-0x1c01c].edu.cmu.cs.stage3[164] [JavaAppLauncher Error] chdir() failed, could not change the current working directory to /Applications/Alice 2.2.app/Contents/Required
7/10/10 Jul 10, 2010 12:09:55 [0x0-0x1c01c].edu.cmu.cs.stage3[164] ERROR: Permission denied
7/10/10 Jul 10, 2010 12:09:57 [0x0-0x1c01c].edu.cmu.cs.stage3[164] [LaunchRunner Error] The main class "edu.cmu.cs.stage3.alice.authoringtool.JAlice" could not be found.
7/10/10 Jul 10, 2010 12:09:57 [0x0-0x1c01c].edu.cmu.cs.stage3[164] [JavaAppLauncher Error] CallStaticVoidMethod() threw an exception
7/10/10 Jul 10, 2010 12:09:57 [0x0-0x1c01c].edu.cmu.cs.stage3[164] Exception in thread "main" java.lang.NullPointerException
7/10/10 Jul 10, 2010 12:09:57 [0x0-0x1c01c].edu.cmu.cs.stage3[164] at apple.launcher.LaunchRunner.run(LaunchRunner.java: 112)
7/10/10 Jul 10, 2010 12:09:57 [0x0-0x1c01c].edu.cmu.cs.stage3[164] at apple.launcher.LaunchRunner.callMain(LaunchRunner. java:50)
7/10/10 Jul 10, 2010 12:09:57 [0x0-0x1c01c].edu.cmu.cs.stage3[164] at apple.launcher.JavaApplicationLauncher.launch(Java ApplicationLauncher.java:52)
7/10/10 Jul 10, 2010 12:09:57 com.apple.launchd[111] ([0x0-0x1c01c].edu.cmu.cs.stage3[164]) Exited with exit code: 1

Going to Get Info, Permissions showed that my primary admin id, Everyone, and World were set to Read & Write. I added my secondary admin and user profiles, but, still no joy.

Checking the Java Utility shows that J2SE 5.0 32 bit is enabled.

I would appreciate any suggestions on how I can get Alice to work under my normal profile (without having to constantly open the disk image).

Many TIA,
shnew
   
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Copyright ©2018, Carnegie Mellon University
Alice 2.x 1999-2012, Alice 3.x 2008-2012, Carnegie Mellon University. All rights reserved.