Alice Community  

Go Back   Alice Community > Alice 2 > Bugs and Troubleshooting

Reply
 
Thread Tools Display Modes
Alice 2.4 doesn't run on 64 bit Linux
Old
jdbrody
Junior Member
 
Status: Offline
Posts: 1
Join Date: Jan 2014
Default Alice 2.4 doesn't run on 64 bit Linux - 01-18-2014, 03:02 PM

Hello,

I think the Linux tarball is missing a 64 bit shared library? When I try to run Alice I get the following error message:
Code:
 sh ./run-alice
Registered succesfully
Java HotSpot(TM) 64-Bit Server VM warning: You have loaded library /home/justin/cs105/Alice 2.4/Required/lib/linux-i586/libgluegen-rt.so which might have disabled stack guard. The VM will try to fix the stack guard now.
It's highly recommended that you fix the library with 'execstack -c <libfile>', or link it with '-z noexecstack'.
java.lang.UnsatisfiedLinkError: /home/justin/cs105/Alice 2.4/Required/lib/linux-i586/libgluegen-rt.so: /home/justin/cs105/Alice 2.4/Required/lib/linux-i586/libgluegen-rt.so: wrong ELF class: ELFCLASS32 (Possible cause: architecture word width mismatch)
If I run Alice from a 32 bit chroot it seems to work fine (with occasional errors about the layout which it seems like are safe to ignore).
   
Reply With Quote
Thank your or the report
Old
djslater107
Administrator
 
Status: Offline
Posts: 144
Join Date: Jan 2007
Default Thank your or the report - 01-19-2014, 11:00 AM

Thank you for your report... We will look into it...

Later,
Don Slater


Don Slater
Alice Team
Carnegie Mellon University
   
Reply With Quote
Reply

Tags
64bit, linux

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Copyright ©2017, Carnegie Mellon University
Alice 2.x 1999-2012, Alice 3.x 2008-2012, Carnegie Mellon University. All rights reserved.