Alice Community

Alice Community (http://www.alice.org/community/index.php)
-   How do I...? (http://www.alice.org/community/forumdisplay.php?f=16)
-   -   What am I doing wrong, with this simple custom method? (http://www.alice.org/community/showthread.php?t=11150)

AvisSoul 06-11-2015 01:31 AM

What am I doing wrong, with this simple custom method?
 
1 Attachment(s)
Hello Alice community!

So, for the past few weeks, I have been attempting to teach myself Alice, through a series of visual and text tutorials. I learn best through visuals, so I try to find photographic examples of how to create various methods properly.

Although I have been mostly successful, I seem to get caught up in fairly simple errors:


I have been attempting too create custom walk methods (body movements in general) but I keep running into the issue of certain limbs becoming detached from the torso.
I have some idea of what I am doing wrong with this, but I would appreciate a little nudge! :D

I just don't understand why one leg is moving properly, but the other does not!:confused:

I have attached an example of a my current custom "Walk" method.

Thanks in advance!

MrMoke 06-11-2015 09:20 AM

Pretty simple Really:
You're telling the skeleton to move forward 1 meter, and since skeleton is the vehicle for the leg, telling the leg to move forward moves it twice as far as the skeleton (1 for Skeleton moves the leg too, +1 for leg.

AvisSoul 06-28-2015 08:42 PM

Thanks
 
Thanks! No more issues here.


All times are GMT -5. The time now is 06:01 AM.

Copyright ©2020, Carnegie Mellon University
Alice 2.x 1999-2012, Alice 3.x 2008-2012, Carnegie Mellon University. All rights reserved.