Alice Community

Alice Community (
-   Bugs and Troubleshooting (
-   -   Alice 2.4 error I can not locate (

Yarnpaw 07-02-2015 11:35 PM

Alice 2.4 error I can not locate
1 Attachment(s)
I searched the forums before posting but none of the suggestions seemed to fix my problem. I get this error message every time I stop my world. I did not find any areas in my program with null values. I have gone through all of my methods and can not find what is causing this error message to occur. I know I must be overlooking something. I figured a second pair of eyes can spot what mine can not. I do not get this message with any of the other worlds I created. This was a world I created to practice what I learned in class.

Error during world stop.

Alice version: 2.4.3 Windows 7

os.version: 6.1

os.arch: x86 Java HotSpot(TM) Client VM

java.vm.version: 20.0-b11

Throwable that caused the error:


at edu.cmu.cs.stage3.alice.core.response.CallToUserDefinedResponse$RuntimeCallToUserDefinedResponse.prologue(

MrMoke 07-03-2015 09:24 AM

Check out your "while world is running" statements and see if you may have made a little mistake in one of them:)

Yarnpaw 07-03-2015 11:32 AM

That fixed it. I apparently had a statement in the end portion of the while the world is running statement that tried to execute when I stopped the world. Thanks for the help. :eek:

MrMoke 07-08-2015 04:40 PM

Happy to point you in the right direction

Nastasya 08-14-2015 02:00 PM

Thank you. And I your tips very useful

All times are GMT -5. The time now is 03:44 AM.

Copyright ©2021, Carnegie Mellon University
Alice 2.x 1999-2012, Alice 3.x 2008-2012, Carnegie Mellon University. All rights reserved.