Alice Community

Alice Community (http://www.alice.org/community/index.php)
-   How do I...? (http://www.alice.org/community/forumdisplay.php?f=16)
-   -   Noob question:problems changing vehicle setting to detach object (http://www.alice.org/community/showthread.php?t=7273)

todd0312 09-24-2011 10:52 AM

Noob question:problems changing vehicle setting to detach object
 
Hello helpful, wise friends:

I'm having a problem with an assignment in a Programming and Logic class. A few weeks ago, I had no experience with Alice, so yes.. this is a noob question.

In my animation, I have a rabbit attached to a locust, which flies up to Alice Liddel, lands, then "is supposed to" get off of the locust, then tip his magician's hat (attached by having the rabbit set as its vehicle).

The problem I am having is getting the rabbit to detach from the locust. I changed the vehicle setting for the rabbit to world; however, I am still unable to get the rabbit to move independently of it. Somehow it has stayed attached. :confused:

After resetting the rabbit's vehicle from the locust to "world" within the fly loop, I was able to get the rabbit to turn to the left, which I was not able to do, for some reason, when I tried to do this outside of the loop. Still, I cannot get the rabbit to move forward and actually detach from the locust.

The only way I could get this part of the animation to look half-way normal was to change the opacity of the locust so it seems to disappear. However, there is still the issue of detaching the hat from the rabbit's head. :mad:

So... I hope this made sense. The assignment is due tomorrow, so... any advice would be greatly appreciated.

Thanks in advance,

Todd

room14 09-25-2011 01:30 AM

Your world please?

adams34 09-25-2011 11:01 AM

You must get relax and try to understand and vulize what is happening

todd0312 09-25-2011 12:04 PM

Alice world with set and detach vehicle issues
 
1 Attachment(s)
Hello again helpful mates:

I have attached my Alice file with which I am having trouble.
The main part of the code to look at is located in a method called “locust.fly”.

The problem seems to be this: I can detach the rabbit from the locust and do whatever I please with the rabbit – but only if I change “set vehicle to world” for the rabbit directly in method “locust.fly”. Using “whiteRabbit set vehicle to world” in “my first method” has no effect.

Conversely, If I enable “set vehicle to world” for the rabbit in my Main Method, but not in the“locust.fly” method, coding behaviors for the rabbit still have no effect.

When “set vehicle to world” for the rabbit is in the “locust.fly” method only, no behaviors coded for the rabbit can be activated in my Main Method. All rabbit behavior must take place in the locust.fly method. Actions I coded for the rabbit after the introduction of “locust fly” into the Main Method fail to activate (the last “Do Together block” at the end of world.my first method( )).

I practice applying methods in “Add objects” view by right clicking the object in the “object tree”, choosing methods, and then applying them. I have no trouble attaching and detaching vehicles in this way. I suppose I can have all rabbit behavior take place in the method meant for the locust to fly up and drop the rabbit off, as the rabbit at least seems to act independently in this method.

There is a good chance that I am missing something really obvious, and if that is the case, I apologize.

Hopefully, I explained this well, but there is a good chance I did not explain it clearly enough. I tried. If you need any clarification, of course, I will be more than happy to do so.

Any advice will be appreciated.

Much thanks in advance,

Excuse any typos and such. In a rush again.

Todd

room14 09-26-2011 12:09 AM

there's nothing wrong with it? the rabbit get's off the locust.:confused:

todd0312 10-01-2011 09:13 AM

Well, I did fix that problem, but I have added more. Care to look at?
 
1 Attachment(s)
[SIZE="3"][B]Hello:

Rude of me not to thank you for responding to my post.

I had a problem with an infinite loop on the tail. It forced me to attach and detach within that particular method. Still haven't fixed that part, but...

I have a part in this animation where a weird Egg shaped dough boy pops out of the hat, but I can't get him to walk in the right direction. Also, his "walk" poses do not work correctly. Is it the walk methods attached, or is it the way I inserted them into the code? I was thinking maybe I was needing to modify the pre-set walk methods, but I am guessing it's some :mad: dummy move I made.

I must sound really lazy :cool: to not just figure it out on my own. I have all this other similar study stuff - and full-time work. Too much code analysis, and the small slot allotted to current programming knowledge may cause: (insert future emoticon for exploding brain here).

Also, the last part of the song that is supposed to be displayed is not showing. Hey... I'm American - brain riddled by television and cheetos. :confused:

Anyway, may be FUN to analyze all the messed up (and really clunky) coding, if that's the kind of thing you are into. :rolleyes: And really... who isn't?

Thanks in advance - I hope.

Todd[/B][SIZE="3"][/SIZE][/SIZE]


All times are GMT -5. The time now is 03:50 AM.

Copyright ©2020, Carnegie Mellon University
Alice 2.x © 1999-2012, Alice 3.x © 2008-2012, Carnegie Mellon University. All rights reserved.