Thread: alice on linux
View Single Post
Alice on 64 bit Ubuntu 8.04 - attempt
Old
goldenfleece
Guest
 
Status:
Posts: n/a
Default Alice on 64 bit Ubuntu 8.04 - attempt - 01-26-2009, 06:05 PM

I saw this attempt by pbceeman (below). I'm trying something very similar on Ubuntu 8.04. I did the a similar jobl/lib replacement using older 1.0.0 jogl files. I may need to change my run-alice file but I may also need to use a different set of jogl files. Another installer mentioned that 32 bit installs are more successful. If anyone figures this out, I'd love to know how you did it.



Quote:
Originally Posted by pbceeman75 View Post
I got Alice to work on Ubuntu 7.10 AMD64 with nVidia drivers. I had to download http://download.java.net/media/jogl/...inux-amd64.zip and replace the contents of jogl/lib under alice with these files. I then modified my run-alice as follows:

/usr/lib/jvm/java-1.5.0-sun/bin/java -classpath ./gnu/getopt-1.0.7.jar:./jogl/lib/gluegen-rt.jar:./jython-2.1/jython.jar:./lib/alice.jar:./jogl/lib/jogl.jar:./xerces-2_6_2/resolver.jar:./vecmath/lib/ext/vecmath.jar:./xerces-2_6_2/xercesImpl.jar:./xerces-2_6_2/xml-apis.jar:./xerces-2_6_2/xmlParserAPIs.jar:./JMF-2.1.1e/lib/customizer.jar:./JMF-2.1.1e/lib/jmf.jar:./JMF-2.1.1e/lib/mediaplayer.jar:./JMF-2.1.1e/lib/multiplayer.jar:./mp3/lib/ext/mp3plugin.jar -Dpython.home=./jython-2.1 -Djava.library.path=./jogl/lib/linux-i586 -Xincgc -Xmx512m -Dalice.useJavaBasedSplashScreen=false edu.cmu.cs.stage3.alice.authoringtool.JAlice -o -e
   
Reply With Quote