View Single Post
Factory Test - An Alice 3 and NetBeans Project
Old
DrJim
Guest
 
Status:
Posts: n/a
Default Factory Test - An Alice 3 and NetBeans Project - 06-29-2009, 07:05 PM

Attached is a brief Alice 3 test I did in response to an earlier posting in the forum ( http://www.alice.org/community/showt...ed=1#post10845 ). The zipped folder contains the Alice 3 Project, a .jar version created in NetBeans, a .bat file to run the .jar version, a "lib" folder needed to run the .jar version and a text file essentially repeating this and the next paragraph. You will need to have Alice 3 and the JRE installed on your machine, but Alice 3 does not need to be running to run the .jar version of the project - just click on the icon for the .bat file.

Caution: Do not copy or move the "lib" folder. This is a very common folder name and you may corrupt other programs having their own "lib" folder.

In respose to the question in the earlier posting, I did not have any trouble with this version of the project. However when I tried to put the individual gears in an array, I was unsuccessful. Just trying to build the (model) array failed completely. I could make the array - but not hit OK to finalize it. Making a "custom array" for "All in --- together" worked, but I got an error actually trying to run the project. Those problems were all in Alice 3, not NetBeans.

Fun, fun, fun.
Attached Files
File Type: zip Factory Test Files.zip (6.30 MB, 28 views)

Last edited by DrJim; 06-29-2009 at 07:12 PM.
   
Reply With Quote