View Single Post
error trying to save in Alice 2.2
Posts: n/a
Default error trying to save in Alice 2.2 - 04-20-2009, 03:11 PM

I just upgraded to Alice 2.2 and tried to add an object a new world; got an error message with the following details. If I run the "IfAliceFailsTryThis.exe" Alice 2.2 runs just fine, but I have to run the executable every time. Does anyone know how to correct this problem?

Alice version: 2.2 1/16/2009

Exception in thread "AWT-EventQueue-0" java.lang.RuntimeException: Scene rendering could not be completed because a scene was not started by a previous call to the IDirect3DDevice7::BeginScene method.

at x7renderer.RenderTargetAdapter.pick(Native Method)

at edu.cmu.cs.stage3.alice.scenegraph.renderer.native renderer.RenderTarget.pick(

at edu.cmu.cs.stage3.alice.authoringtool.util.RenderT argetPickManipulator.mousePressed(RenderTargetPick

at edu.cmu.cs.stage3.alice.authoringtool.util.RenderT argetMultiManipulator.mousePressed(RenderTargetMul

at java.awt.AWTEventMulticaster.mousePressed(Unknown Source)

at java.awt.AWTEventMulticaster.mousePressed(Unknown Source)

at java.awt.Component.processMouseEvent(Unknown Source)

at java.awt.Component.processEvent(Unknown Source)

at java.awt.Component.dispatchEventImpl(Unknown Source)

at java.awt.Component.dispatchEvent(Unknown Source)

at java.awt.EventQueue.dispatchEvent(Unknown Source)

at java.awt.EventDispatchThread.pumpOneEventForFilter s(Unknown Source)

at java.awt.EventDispatchThread.pumpEventsForFilter(U nknown Source)

at java.awt.EventDispatchThread.pumpEventsForHierarch y(Unknown Source)

at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

at Source)

Last edited by scoutwert; 04-20-2009 at 03:38 PM. Reason: incorrect problem description
Reply With Quote