Alice Community  

Go Back   Alice Community > Alice 2 > Bugs and Troubleshooting

Reply
 
Thread Tools Display Modes
Problem with latest Alice 2.2 (12/01/2011)
Old
MrMoke
Senior Member
 
MrMoke's Avatar
 
Status: Offline
Posts: 501
Join Date: Sep 2007
Location: Austin, Texas
Default Problem with latest Alice 2.2 (12/01/2011) - 01-20-2012, 09:04 PM

Hi Everyone-
I installed the latest version of 2.2 recently, and it's been going OK until today. I was going to show on old program to some of my students, and it started malfunctioning immediately. I spent a 1/2 Hr. this evening trying to figure out what it is, and it seems to be a problem in passing a parameter more than one level deep.
In the original, I passed an object from World down two levels, and the object references worked fine two levels deep. That is no longer the case.

To save memory I created a simple demo to illustrate the problem. The prints and moves indicate what is being referenced at each call level. Notice that at level 02 the target reference is not passed, and that the soccer ball moves to world.

This was not a problem with previous versions of 2.2.
Attached Files
File Type: a2w Passing-Problem.a2w (196.3 KB, 0 views)
   
Reply With Quote
Bug with this version
Old
aikmin
Senior Member
 
aikmin's Avatar
 
Status: Offline
Posts: 85
Join Date: Mar 2008
Default Bug with this version - 01-23-2012, 08:23 AM

This is a bug with this version (12/01/2011). Please wait and download the version coming out sometime in February or go back to an earlier version.
   
Reply With Quote
Ok
Old
MrMoke
Senior Member
 
MrMoke's Avatar
 
Status: Offline
Posts: 501
Join Date: Sep 2007
Location: Austin, Texas
Default Ok - 01-23-2012, 08:17 PM

Thanks for the Feed-back. My post was just to point it out in case someone else got stuck. Looking forward to the February release. Would this bug also affect any attempts to do recursion?
   
Reply With Quote
Tick-Tock
Old
MrMoke
Senior Member
 
MrMoke's Avatar
 
Status: Offline
Posts: 501
Join Date: Sep 2007
Location: Austin, Texas
Default Tick-Tock - 02-25-2012, 12:06 PM

Problem is now fixed in February release. Thanks aikmin

Last edited by MrMoke; 03-18-2012 at 02:13 PM.
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Copyright ©2019, Carnegie Mellon University
Alice 2.x 1999-2012, Alice 3.x 2008-2012, Carnegie Mellon University. All rights reserved.