Alice Community  

Go Back   Alice Community > Alice 2 > Suggestion Box

Reply
 
Thread Tools Display Modes
Remainder to Modulo
Old
Niteshifter
Guest
 
Status:
Posts: n/a
Default Remainder to Modulo - 07-18-2009, 02:01 AM

I think the "IEEERemainder" or "Remainder of..." function should be changed to Mod or % to match its proper term. Since it would be like having floor be named as "nextSmallestInt" or ceiling as "nextHighestInt".
   
Reply With Quote
Old
x2495iiii
Super Moderator
 
x2495iiii's Avatar
 
Status: Offline
Posts: 3,508
Join Date: Dec 2008
Location: Somewhere in the Continental U.S.
Default 07-26-2009, 12:17 AM

I was always taught it was called a "modulus," but it looks like it could be both. I personally think they should take it one step further and have a nice guide which explains in detail each function's...function, as well as some possible synonyms for it (modulus, modulo, etc.).


(')>
   
Reply With Quote
Old
Niteshifter
Guest
 
Status:
Posts: n/a
Default 07-31-2009, 08:40 PM

Yeah, I thought it was modulus as well, but modulo seems to be used more frequently for some reason .

The idea with the guides sounds like a good idea as well.
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Copyright ©2020, Carnegie Mellon University
Alice 2.x 1999-2012, Alice 3.x 2008-2012, Carnegie Mellon University. All rights reserved.