View Single Post
Posts: n/a
Default 05-08-2009, 07:08 PM

I tried making an event that says
"While skeleton is within (tombstone's width / 2) of tombstone is true
Begin: Nothing
During: Nothing
End: world.collision tomb (which is a method that tells the skeleton to move backwards the same speed it moves forward with the up arrow presses)"

But, attempting to test it, the skeleton just moved backwards no matter where it was located.

EDIT: >< Idiot's mistake, just realized I had the world.collision tomb method looping in the world.start method...

EDIT: After fixing that problem, the event just isn't working properly at all. I'll be partway inside the tombstone, and then suddenly start bouncing around randomly.

EDIT: (Sorry for all the edits, but as I fool around trying to get it to work, new problems are going to arise) I tried switching it so that it says "While tombstone is within (skeleton's width / 2) of skeleton
Begin: Nothing
During: Nothing
End: world.collision tomb (changed the method so that rather than 'bouncing' back, it just moves a small amount so you can't really tell it's moving backward)"
It still does nothing. I changed it because I figured that the tombstone's width /2 wouldn't work well, because the tombstone is sort of oblong. Still does nothing though.

EDIT: I thought my trouble was with the method making the character move, but a test revealed that the program just isn't detecting collision at all.

Last edited by tyler-id; 05-08-2009 at 07:42 PM.
Reply With Quote