Alice Community  

Go Back   Alice Community > Alice 2 > How do I...?

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Collision clipping
Old
HorusLupercal
Junior Member
 
Status: Offline
Posts: 7
Join Date: Apr 2012
Location: Mwhahaha right.
Default Collision clipping - 05-08-2012, 05:42 PM

I've set up a collision detection using the in front of, to the left of, etc. and it works fine most of the time. For some reason every once in a while the object that is in motion and collides with the walls will move way more than the 0.5m that I have set up in the collision. When this happens it also pushes the object through other walls.

I've modeled my collision off of some of the tutorials that SFunk and others have directed me towards and they don't have this issue. Is there something underlying that I'm missing or perhaps I need to be more precise with my walls or make them spaced further apart?

On another note, I have objects that my main object is going to pick up (a sword and shield). I have set the objects in a world variable and run a for all objects in the variable when knight is within 2m they set opacity to 0%. For some reason this function is not working at all. Even when the knight is directly on top of the object. Thoughts?
   
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Copyright ©2021, Carnegie Mellon University
Alice 2.x 1999-2012, Alice 3.x 2008-2012, Carnegie Mellon University. All rights reserved.